jump to navigation

Guida installazione driver ATI-FGLRX con AIGLX support novembre 7, 2007

Posted by linuxiano in 3d, Ati, Beryl, compiz, compiz-fusion, grafica, Linux, multimedia, Note su Linux, schede video, xorg.
trackback

Come promesso, ecco una breve guida per l’installazione dei driver ATI con il supporto nativo per AIGLX.
Allora:
innazitutto scarichiamo i driver da QUI.
scompattiamo e compiliamo:
bash ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Ubuntu/gutsy

Se non l’avete fatto, rimuoviamo i precedenti driver in questo modo:
sudo apt-get remove fglrx-amdcccle xorg-driver-fglrx fglrx-kernel-source xorg-driver-fglrx-dev fglrx-kernel-$(uname -r)

A questo punto installiamo; entriamo nella directory dove ci sono tutti i file decompressi e diamo un bel:
sudo dpkg -i *.deb

Adesso usiamo module-assistant in questo modo:
sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant build fglrx
sudo module-assistant install fglrx
sudo depmod -ae
sudo modprobe fglrx

Poi per evitare che vengano caricati moduli fglrx alternativi, editiamo il seguente file:
gedit /etc/default/linux-restricted-modules-common
ed aggiungiamo:
DISABLED_MODULES=”fglrx”

Per terminare togliamo da /etc/xorg.conf le seguente stringhe:
Section "Extensions"
Option "Composite" "Disable"

e impostiamo AIGLX in questo modo:
Option "AIGLX" "off"

Questo è tutto!
N.B. non arrabbiatevi con me se non funziona con le vostre schede…… è ancora in fase di mooolto testing, quindi non è detto che funzioni su tutte le schede!

Commenti»

1. Garret - novembre 7, 2007

Io ho un portatile con una shceda ati e ubuntu gutsy. Ho abilitato i driver da gestione driver con restrizioni. I driver messi da questo tool sono questi qui oppure sono una versione più vecchia?

2. linuxiano - novembre 7, 2007

non sono questi….
questi driver sono in una versione di testing, non è ancora stata rilasciata una versione stabile di questi con supporto nativo ad AIGLX.

3. skizzo167 - novembre 7, 2007

qualcuno ha provato con una Ati X700 ?

4. sfinge - novembre 8, 2007

Perchè AIGLX off? digitando “sudo nano /usr/bin/compiz” e si aggiunge in # Driver whitelist
WHITELIST=”nvidia intel ati radeon i810“ aggiungendo fglrx dopo i810, AIGLX parte, almeno nella mia ATI X1800

5. lorenzo - novembre 8, 2007

@sfinge
Esatto. Comunque in merito alle prestazioni dei driver ho già segnalato le problematiche principali:
http://www.bracuccia.net/2007/10/30/brevi-note-dopo-una-settimana-con-i-nuovi-driver-ati-8423/

6. mic - novembre 8, 2007

Si provato con la X700 (su di un portatile)
funzionano
unica cosa non so perchè mi fa dure righe verdi in basso a destra nello schermo di 0,5 x 4 cm
se pass al terminale e torno ad X scompaiono ma dopo pochi minuti riappaiono, come se ci fosse un problema di rendering non so.

Per la whitelist mi sa mi sa che non basta, almeno io sulla x700 con gutsy ho dovuto modificare /usr/bin/compiz (non è altro che uno script bash) facendogli saltare i vari controli, poichè se si accorge che è una ati lui cerca XGL e non trovandolo dà errore.

7. fabioedoardoluigialberto - novembre 28, 2007

ciao anche io ho quei problemi, compaiono in basso a sinistra in un quadrato di circa 3 cm.
ho una mobility radeon x600se su toshiba m50-176 con Fedora 8. I driver li avevo anche con la 7 ma non avevo lo stesso problema. A volte mi capita anche di vedere delle righe che seguono il puntatore, come fossero delle scritte piccolissime su tre righe, illeggibili (non sono scritte…).

in tutto questo, fglrx-info mi dice tutto ok ma compiz non va. come spesso accade, non carica il gestore delle finestre e
dopo qualche secondo torna automaticamente a metacity.

Altra cosa: il mio /usr/bin/compiz non è affatto uno script!! come lo modifico? forse c’è qualche altro script che a sua volta chiama /usr/bin/compiz…

8. fabioedoardoluigialberto - novembre 28, 2007

da questo sito:
http://natonelbronx.wordpress.com/2007/10/24/ati-driver-fglrx-842-arrivano-aiglx-e-compiz-per-i-possessori-di-schede-ati/

[…]
Non c’è il supporto al kernel 2.6.23 per ora, atteso per la prossima release! Attenzione quindi (il supporto a questo kernel manca per un problema riscontrato con l’architettura x86_64)
[…]


Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: